MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000048Kalkules[All Projects] Generalpublic2014-07-12 07:082017-03-21 15:17
Reporterguest 
Assigned ToJardo 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.9.4.23 
Target Version1.9.5.24Fixed in Version1.9.5.24 
Summary0000048: Add another operation to finished calculation
DescriptionWhen I end my kalkulation, after pressing key (eg. 2 + 3 ) I get 5, I would really want to get a possibility to add another 4 (so I would get 9 - yet, all resets and I get, well, 4 (the last number added) - the answer gets selected (and I don't think it is good!). Is it possible to change / add a feature, so
we could get a really powerfull software? The best option would be to
change the key action to kalkulate the currently entered expression
and not select everything.
TagsNo tags attached.
Attach Tags (Separate by ",")
Attached Files

- Relationships

-  Notes
(0000767)
Jardo (administrator)
2014-07-12 07:10

I believe what you're describing is the programs default behaviour. You normally write 2+3, press [=], the result will show, and then you just press [+][4] and the expression changes to 5+4 .... this however depends on your settings. Go to Preferences/Show preferences.../Behavior and check the setting "When inserting an operator after caclulation". It should be set to the middle option. You can also experiment with other options.
(0000768)
guest (reporter)
2014-07-12 07:12

I tried and trien and something came out: the said feature works only while using the numerical keyboard and it's enter, but doesn't work for main keyboard digitals and the "main" enter! Could You add also the events for the said keys?
(0000769)
Jardo (administrator)
2014-07-12 07:16

The problem is that when you use the "main" keyboard to enter the + sign, you have to pres the shift key. But the shift keys function is to suppress the automatic insertion of the last result. I will change this function to the ctrl key and then it should work.

- Issue History
Date Modified Username Field Change
2014-07-12 07:08 guest New Issue
2014-07-12 07:08 guest Status new => assigned
2014-07-12 07:08 guest Assigned To => Jardo
2014-07-12 07:10 Jardo Note Added: 0000767
2014-07-12 07:12 guest Note Added: 0000768
2014-07-12 07:16 Jardo Note Added: 0000769
2014-07-12 07:16 Jardo Target Version => 1.9.5.24
2014-07-20 20:30 Jardo Status assigned => closed
2014-07-20 20:30 Jardo Resolution open => fixed
2014-07-20 20:30 Jardo Fixed in Version => 1.9.5.24
2016-01-09 15:14 guest Status closed => feedback
2016-01-09 15:14 guest Resolution fixed => reopened
2017-03-21 15:17 Jardo Status feedback => resolved
2017-03-21 15:17 Jardo Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker